people writing #RustLang:
method #1: result.and_then(|()| another_thing_that_results()).and_then(|()| yet_another_thing_that_results())
method #2: result?; another_thing_that_results?; yet_another_thing_that_results? Ok(())
I tend to catch myself doing the first form because of #Elixir but now I'm slowly replacing things with method #2 because it's way more readable
how do people tend to go about this?
the latter also seems a lot easier to log?